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Features 

·  ECU plugs directly into Bosch Motronic 35-pin looms 

·  Uses all existing sensors and wiring; no modifications required 

·  Uses the same physical mounting points in the vehicle 

·  PC connection through either serial or USB leads 

·  Data logging through PC or onboard SD memory card 

·  Load and save calibration maps to your PC 

·  All parameters adjustable at runtime 

·  Choose any load sensor – airflow meter, TPS, MAF, MAP 

·  Use standard peak & hold or modern saturated injectors 

·  Use any ignition system – distributor, twin-plug distributor, DIS coil pack or individual coils 

·  18 programmable speed sites 

·  14 programmable load sites 

·  Map switching at runtime – switch between sport/economy modes or different fuel grades 

·  Two 3D fuel maps with injector resolution of 4 microseconds 

·  Two 3D ignition maps with 0.5 degree increments 

·  Optional interpolation/mapping modes in all maps 

·  Optional password entry to protect your maps 

·  Adjustable fuel priming pulse and temperature 

·  Adjustable cranking pulse width and flood clear modes 

·  Fuel decay from cranking to running 

·  Fuel enrichment after engine start 

·  Idle valve decay from cranking to running 

·  Ignition advance when cranking 

·  Fuel cut rev limiter – alternating between cylinders or full cut, with hot/cold settings 

·  Injector opening time v Voltage maps for different injectors 

·  Adjust fuel maps for different injector flow rates or fuel pressures 

·  Transient fuel enrichment with any load sensor 

·  Multiple sensitivity and enrichment under transient conditions 

·  RPM correction and durations for transient enrichment 

·  Transient enrichment taper back to normal running 

·  Two stage ignition rev limiter – alternate between cylinders or full cut with hot/cold settings 

·  Ignition timing adjustment through engine temperature and / or air temperature 

·  Transient ignition advance – specify maximum advance or retard per revolution 

·  Dwell v RPM map 

·  Dwell v Voltage map 

·  Engine temperature adjustment for cranking and running (cold start and warm up) 

·  Temperature adjustment under idle conditions 

·  Air temperature correction 

·  Temperature sensor failure modes 

·  Altitude correction 

·  Wideband or narrowband oxygen sensor input 

·  Closed or open loop lambda sensor feedback 

·  Adjustable lambda authority and sampling rates 

·  Idle control via PWM valve or ignition spark scatter 

·  Closed or open loop idle control with adjustable authority and sampling rates 

·  Programmable idle valve decay for sudden deceleration 

·  Two programmable outputs for shift light / tachometer / cooling fan / warning lamps etc 

·  Record minimum and maximum outputs to and from ECU 

·  Crank sensor diagnostic log with export facility
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Before you get started… 

The DRH Performance ECU has two high current injection outputs and three high current ignition outputs. Each 

output can hold a constant current of 10 Amps maximum. Ignition coils should have a primary resistance of 

greater than 0.6 Ohms. Low impedance injectors (with a resistance of less than 6 Ohms) should always be used 

in peak-and-hold mode (set in software). 

 

Support is available from Canems in sourcing components, installing the engine management system and 

programming the ECU to suit your requirements. The ECU is designed to operate in conjunction with easily 

obtainable components. It is our policy to design systems that require no unique hardware, and will always 

endeavour to have spares available in the future.  

 

PC Tuning software displays all lambda sensor inputs as air fuel ratios (AFRs). It should be noted that only 

wideband lambda sensors are capable of giving a true reading over a wide range of AFRs. Narrow-band sensors 

can only indicate an over-lean (or over-rich) mixture, though the ECU, tuning software and data logs will of 

course reflect this behaviour. 

 

Rolling road time is expensive, so our software is designed to be quick and easy to use; even for people with 

little experience. All fuel and ignition maps can be accessed with keyboard shortcuts, and you can change 

values with one touch of the keyboard. There is no need to waste valuable time when typing individual values 

and you can even tune your 3D maps visually, with the aid of graphical representations. 

 

Our ECUs are designed to give total reliability and total control over engine parameters. However, full 

responsibility for the engine and vehicle in question remains solely with the owner. Canems can in no way be 

held responsible for damage or injury caused by incorrect fitting procedures, failure in use or neglect of 

appropriate safety measures.   
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Basic terminology 

 

Pulse width 

 

Pulse width is a measurement of time. Typically used to describe the amount of time for which a fuel injector is 

held open. The longer an injector is held open for, the more fuel is able to flow into the engine. Therefore, 

there is a direct relationship between fuel mixture and injector pulse width. Due to the fast switching nature of 

fuel injectors, pulse width will typically be measured in milliseconds (thousandths of a second).  

 

Duty cycle 

 

Duty cycle describes the amount of time for which an output is held ‘on’. It is measured as a percentage. For 

example, an injector held open for 8 milliseconds, then closed for 2 milliseconds, has a duty cycle of 80%. As 

RPM increases, fuel injectors have an increasingly short space of time in which to inject the required fuel. It 

doesn’t help that the engine will probably want more fuel at high speed either. If the duty cycle exceeds 100%, 

this means the injector is open full-time. It has reached the limit of its flow capabilities and is no longer able to 

supply more fuel. 

 

PWM 

 

Standing for Pulse Width Modulation, PWM is used by the ECU to vary the amount of power sent to a device 

(such as an idle control valve). For example, an output switching with a duty cycle of 50% will effectively 

provide half the power available at 100% duty cycle. Thus, changing the duty cycle will change the average 

power available to the device. A PWM frequency of 80Hz means that the on / off switching pattern repeats 

itself 80 times per second.  

 

 

 

 

 

 

 

 

 

 

 

Open loop / closed loop 

 

Open loop control refers to an ECU operation that has no feedback. For example, if a fuel setting in the ECU has 

been told to inject a certain amount of fuel, it will do this, regardless of whether the engine is already running 

too rich or too lean. 

 

Closed loop control means that feedback is used. The complement to the example above would be a lambda 

sensor, which would tell the ECU that the engine is running too rich or too lean. The ECU would then use this 

feedback to adjust fuel delivery accordingly. 
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Using the software 

 

To install the software, insert the CD into your CD-ROM drive. The software installation process should begin 

automatically. If this is not the case, click on the ‘My Computer’ icon on your desktop and right-click the CD-

ROM drive. Now click ‘Browse’. 

 

 

 

Double-click the icon named ‘Setup’, and this will start the installation process. 

 

A message will appear once the installation has completed successfully. This means you can start the DRH 

Performance Tuner software either by double clicking on the DRH icon on your desktop or by accessing the 

Start > Programs menu. 

 

 

Connecting the ECU 
 

Once the ECU is installed in your vehicle with an ignition-switched power supply, you can test the 

communication between the tuning software and the ECU module. 

 

The first step in this procedure is to connect the supplied communication lead between the ECU and your 

computer. The communication lead has a female connection at one end and male at the other. Therefore, it is 

not possible to connect the two items incorrectly. 

 

On your computer, the communication lead plugs into a spare serial / COM port. Most computers have such a 

connection. If your computer does not, connect the USB adaptor supplied with your ECU kit instead. 

 

Once the communication lead has been attached, you can start the DRH Performance Tuner software. This will 

display the default screen. 
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The DRH Performance Tuner software will automatically detect the ECU. 

 

 

 

Once the software has managed to locate the ECU, all settings will be downloaded to your computer. This 

process takes only a few seconds, and is the starting point from where you can begin to modify the ECU 

settings – referred to as ‘mapping’. 

 

 

 

Engine temperatures can be viewed in 

either degrees Celsius or degrees 

Fahrenheit. To set your preference, click 

‘View > Display preferences’.  
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Inputs, outputs and real-time data 
 

Under the ‘View’ menu, you will find options to display all inputs and outputs to the ECU. As a default, the 

software shows the main dashboard and displays the input and output values in a textual format. 

 

The Mapping Essentials screen (‘View > Mapping essentials’) is designed to show the most important data, so 

it is recommended to load this window when mapping is in progress. For easy access when mapping, you can 

also press F1 to view this screen. 

 

 

 

 

 

Along with textual readouts for inputs, outputs and feedback, 

there are graphical displays that also represent this data. An 

example of this is the Output Graphics window (‘View > Output 

graphics’). 

 

A selection of analogue style gauges can also be viewed on-

screen, along with an ‘ECU status’ window which is used to 

indicate the status of various outputs and ECU features. 

 

 

 

Loading and saving files 

 

It is a wise precaution to save your ECU settings onto your computer. This is particularly true during the 

mapping process, where it is very easy to upset the engine tuning and therefore you may need to reload your 

previous settings. To save the ECU settings, click ‘File > Save calibration’.  

 

When loading a calibration file, the engine should not be running. The ECU must of course be connected to the 

host computer and have a voltage supply. To load a calibration file, click ‘File > Load calibration’. 

 

Before closing the Tuner software, a user will automatically be asked if they wish to save their changes. It is 

recommended that a backup copy is frequently saved during the mapping process. 
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Firmware Files 
When major changes need to be made to your ECU, you’ll need to change the software inside the ECU itself. 

This is called ECU firmware. To get the latest firmware files, visit the Canems website. From here, upgrades for 

your ECU can be downloaded free of charge. Firmware files are also distributed with your installation CD 

though naturally they may not be the most recent. 

 

Uploading firmware files 

Changing the firmware in the ECU is a simple process. It is recommended to backup your settings before 

uploading firmware, although they are not overwritten during the upload process. With the ignition off, 

connect the tuning lead to your computer and open the DRH Firmware upload software. This will be in your 

‘Start > Programs > DRH Performance’ folder. 

 

 

 

Now, select ‘Open file’. Choose which firmware version you’d like to use by clicking ‘Open’. (This screen shown 

below left) 

 

  

 

To begin the upload process, simply choose the COM port to which the ECU is connected (the software will tell 

you which ports are currently active) and then click ‘Start Update’. Now turn on the ignition. The firmware 

upload takes approximately fifteen seconds, after which the ECU is ready to use. (Shown above right). 
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ECU Setup 

 

Before attempting to start the engine, it is vital to 

complete the ‘basic setup’ options (‘ECU setup > 

Basic setup’). 

 

Mapping mode on?  

The DRH Performance ECU has inbuilt interpolation 

on all maps. This means that values from adjacent 

sites will always be taken into consideration when 

the ECU is locating a value. For example, consider the 

case where the ignition timing is specified as 20º at 

2000 RPM and 26º at 3000 RPM. Using interpolation 

between the two values, the ECU will calculate that 

an advance figure of 23º is required at 2500 RPM. 

 

The effect of interpolation is to smooth the transition 

from site to site, blending values so that there are no 

sudden jumps in either fuel mixture or ignition 

timing.  

 

When you are setting up the ECU (known as 

‘mapping’) it can be advantageous to turn off the 

interpolation mechanism. Without interpolation, 

changes to a single site in a map will produce a much more obvious change in engine performance. Mapping 

with interpolation turned on would require all adjacent sites to be altered before a significant change can be 

recognised. 

 

2D Map mode? 

If the ECU is being used as an ignition-only controller (typical with carburettor conversions, such as a Porsche 

911 with PMO’s), then it can be used in a 2D only mode. This is similar to running a distributor without a 

vacuum advance unit. In nearly all cases it is advantageous to use a load sensor, but this option allows 

operation without. 

 

Use separate 2D maps when closed/open throttle switch active? 

The original Motronic ECU has two throttle switches rather than an infinitely variable potentiometer. These 

switches tell the ECU whether the throttle is either fully open or fully closed. Using these two settings, you can 

force the ECU to use a separate 2D map for fuel quantity and ignition timing whenever the throttle is fully open 

or fully closed. 

 

Use RPM smoothing at idle? 

Selecting this option can improve idle quality with high lift / large overlap camshafts. The ECU will take an 

average reading of engine RPM, rather than a real-time reading. Fuel quantity and ignition timing requirements 

are then calculated from this average measurement which can prevent a ‘hunting’ idle condition. 

 

Use enhanced noise rejection at idle? 

This setting is designed to improve engine starting by rejecting any unexpected noise from the crank sensor 

signals. It is recommended to leave this setting turned on. 
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Use peak and hold injectors? 

The DRH Performance ECU is designed to use either the original peak-and-hold injectors (found on all Motronic 

ML1.x installations) or more modern saturated injectors. You must select this option if your engine is fitted 

with peak-and-hold injectors, otherwise there is a risk of overheating the ECU and/or fuel injectors. 

 

Ignition system 

 

• Standard distributor. The vehicle is fitted with a single ignition coil and distributor (all standard Motronic 

installations). 

 

• Twin-plug distributors. The vehicle has a twin plug conversion (a relatively common modification for tuned 

911s). There are two coils and two distributors. 

 

• Distributorless (wasted spark). The vehicle is using a DIS coil pack conversion. 

 

• Distributorless (pencil coils). The ignition system is using an external amplifier system. In this case, the ECU 

provides a low current 5V logic signal, rather than acting as a high current switched earth.  

 

For more details see “Modifying your ignition system” 

 

Setting speed and load sites 

 

You must choose suitable values for the ECU Speed Sites. These values are used in all of the 3D ECU maps, and 

as such they help to determine fueling and ignition parameters for all engine speeds. To view the speed sites, 

click ‘ECU setup > Speed sites’. 

 

 

 

The speed sites should be spread across a suitable range from approximately 500 RPM up to the maximum 

expected engine speed.  It is common to group speed (and load) sites together more closely in some places, 

corresponding to the most frequently used engine speeds (or loads). This will allow a greater degree of fine-

tuning in the most commonly used areas in a 3D map, ultimately leading to improvements in economy or 

performance – whichever is desirable. 
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Speed sensing & TDC location 
 

The DRH Performance ECU measures engine speed and crank sensor location via two crank sensor signals. By 

analysing the signal from multiple flywheel teeth, the ECU is able to calculate engine speed. A separate TDC 

reference pulse enables the ECU to recognise crankshaft position within the engine.  

 

All Motronic ML1.X systems have these two crank sensors already installed. Despite this, it is advisable to check 

the static timing to ensure that your ignition timing is as accurate as possible. 

 

 
 

To check the static timing in your system, the engine must be running with a strobe light attached to HT lead, 

number one cylinder. In the DRH Performance Tuner software, click ‘ECU setup > Static timing’. Select the 

option to lock ignition timing, and choose a suitable figure for ‘Locked timing advance figure’. Click ‘Save 

settings’. 

 

The ECU will now fix the ignition timing at this figure exactly. It doesn’t matter whether the engine speed 

increases or decreases, or whether there is any change in engine load. 

 

Verify with the strobe light that the spark is occurring at the correct time. If not, use the ‘Advance trim’ setting 

to move the static timing position. You can move the ignition point in 0.5 degree increments. When the strobe 

light figure matches the ‘Locked timing’ figure, unselect the ‘Lock timing?’ check box, and remember to click 

‘Save settings’. 

 

Take care! If you’ve upgraded to distributorless ignition, remember that your strobe light will see two sparks per 

720 degrees of crankshaft rotation. If your strobe light has an advance/retard knob, then this can confuse 

matters. If in any doubt, lock the timing at 0.0 degrees and set the static timing to TDC. 

 

Load sensing 
 

Most of the main maps in the DRH Performance ECU are 3D. This means each map has a speed-referenced axis 

and a load-referenced axis. The speed axis is based on how quickly the engine is turning, while the load axis is 

based on how hard the engine is working. For example, an engine pulling top gear up a hill is working much 

harder than an engine coasting downhill in second gear. This is where the load sensor comes in – it can 

differentiate between the two conditions. 

 

On standard Motronic installations, vehicles are fitted with a ‘barn door’ air flow meter. These are underrated 

devices in terms of accuracy, but they do wear badly due to moving parts and electrical contacts. Modern 

equivalents include MAP sensors, MAF sensor and throttle position sensors. All four load measuring devices are 

compatible with the DRH Performance ECU. 
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After installing a load sensor, you must specify the minimum 

and maximum ADC readings. The DRH Performance ECU has 

three ADC (analogue to digital converter) channels. ECU pin 

seven is typically used as the main load sensor input. 

 

The ADC channels count from 0 to 255, with 0 equating to 0V 

and 255 equating to 5V. In the illustrated example, maximum 

load is indicated by an ADC value of 246, or 4.82 Volts. 

 

If you are using a throttle position sensor to measure load 

(common with individual throttle body [ITB] setups), you 

must reset these figures after setting the engine idle speed. 

 

We have found the best way to measure load with ITB 

arrangements is a blend of TPS and MAP readings. You 

therefore have the option to ‘blend’ the analogue inputs 

from Pin 7 (usually connected to a MAP sensor) and Pin 3 

(usually the TPS input). 

 

 

 

 

 

 

If you set a bias of 35%, this means the ECU will take 35% of 

the load measurement from the MAP and 65% from the TPS. 

 

It is also possible to invert the readings on the ADC input 

channels. To do this, click ‘ECU setup > ECU channel setup’. 

 

This will display the screen to the left, where each of the three 

ADC channels have a corresponding option. 

 

 

The DRH Performance ECU has twelve programmable load sites, which are used in all 3D maps, most typically 

to calculate fuel quantity and ignition timing requirements. To access the load sites setup, click ‘ECU setup > 

Load sites’. This will display the screen below: 

 

 
 

Load sites should be programmed to fall within the range of possible load values (0 to 100%). Load values 

should increase in size from left to right. After changing load site values, click ‘Save settings’. 
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Throttle Switches 

 

The original Motronic ECU has two throttle switches rather than a variable potentiometer. These switches tell 

the ECU whether the throttle is either fully open or fully closed. Using these two settings, you can force the 

ECU to use a separate 2D map for fuel quantity and ignition timing whenever the throttle is fully open or fully 

closed. 

 

To access the settings for the throttle switch setup, click ‘ECU setup > Throttle switches’. These settings are 

shown to the right. 

 

Typically, Motronic systems will connect the closed throttle switch to ECU pin 2, and the open throttle switch 

to ECU pin number 3. 

 

Even if you have removed the original throttle switches, you can still mimic their behaviour in software. For 

example, setting the throttle switch inputs to pin number seven would take a reading from the main load 

sensor such as a TPS with individual throttle bodies. 

 

ECU Password Control 
 

To secure your ECU settings, it is possible to place a password lock on the ECU. This will prevent viewing or 

alteration without authorisation. To set a password, click ‘ECU setup > Password control’. 

 

Select the option to ‘Enable password control’, and enter your six digit alphanumeric password. Remember to 

click ‘Save settings’. 

 

The next time you restart the ECU AND reload the DRH Performance Tuner software, you will be prompted for 

the password before any communication is granted with the ECU. 

 

 

 

 

If you have forgotten the password or would like to force entry into a 

previously locked ECU, this is also possible, although all settings in the 

ECU will be completely removed.  

 

 

 

 

 

If you do need to force entry to the ECU, press the ‘F8’ 

key when the ‘Password Entry’ screen appears. This 

will display the warning message shown to the right. 

 

If you click ‘Accept’, all data in the ECU will be wiped. 

DO NOT attempt to start the engine until suitable 

settings have been restored.
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Injector opening times 

 

A fuel injector is activated when the ECU allows current to flow through the internal solenoid. Before fuel 

actually begins to flow, the solenoid must open an internal valve. This process takes a finite amount of time 

and is dependant on the voltage available. Lower voltages will take longer to activate the solenoid an open the 

valve. 

 

 

 

 

 

 

 

 

 

The diagram above shows that the total injector pulse width actually consists of two separate phases; that in 

which the injector is opening and there is negligible fuel flow, and that in which fuel is actually released. This 

being the case, the ECU features a programmable map of injector opening time against vehicle voltage. To view 

the map, click ‘Fueling > Injector opening times’. 

 

 

 

For each possible voltage, there is a programmable opening time (in ms). Most injectors have an opening time 

of between 0.8 to 1.0 milliseconds at 12V. Injector opening times can be specified to the nearest 64 

microseconds.  

 

After making changes, click ‘Save settings’ to store the values in the ECU. 
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Priming, cranking and flood clear modes 

 

When the ECU receives power (ignition is turned on), all fuel injectors in the system will deliver a short ‘priming 

pulse’ to start the engine. The priming pulse is programmable in length, and can be temperature dependant. 

Typically the priming pulse is not required when engine temperature is above 30ºC. To modify the priming 

pulse settings, click ‘Cranking/startup > Priming pulsewidth’. 

 

 

 

If your engine fails to start, it is recommended to keep the ignition on rather than restarting the ECU before 

every attempt – this will prevent the addition of more than one priming pulse which could lead to a flooded 

engine.  

 

Once the engine is running, the ECU will revert to a main 3D fuel map, where it will work out how much fuel is 

required. At cranking speeds however, the ECU will use a preset injector pulse width. This is set under 

‘Cranking/startup > Pulsewidth and flood clear’. 

 

In case the engine happens to flood during 

cranking, there is an optional ‘Flood Clear’ 

setting available. 

 

If selected, no fuel will be injected during 

cranking provided that the throttle is fully 

open. This helps to clear any fuel residue from 

the cylinders before further attempts are 

made at starting the engine. 

 

 

The injector pulse width should be set at a suitable value for hot cranking conditions. This can easily be 

determined by trying to start the engine with different values once the engine is thoroughly warmed through. 

It’s advisable to start with a low value to prevent flooding the engine.  

 

The injector pulse width can be specified to the nearest 64 microseconds. After changes have been made, click 

‘Save settings’ to store the value in the ECU. 

 

To ensure correct fueling at all temperatures, the cranking pulse width is corrected by the coolant temperature 

sensor. For more information, see the section entitled ‘Cranking correction’. 
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Cranking Decay 

 

 

 

If an engine fails to start immediately, the existing fuel is not burnt. This can soon lead to a build-up of fuel in 

the cylinders which will soak the spark plugs and make starting even more difficult. Under ‘Cranking/startup > 

Cranking decay’. There is therefore a 2D map available which will acts to decay the fuel quantity after a certain 

time period. More accurately, the cranking pulse width is increased by a certain percentage to begin with, and 

this percentage tapers to zero after perhaps one hundred crankshaft revolutions. 

 

Startup enrichment 

 

 

 

Once the engine has fired, the ECU will enter a condition known as ‘after start enrichment’. The aim of this is to 

richen the mixture so that the transition from cranking to running can be performed smoothly. To view the 

after start enrichment settings, click ‘Cranking/startup > Startup enrichment’. This will display the screen to 

the above. 

 

The after start enrichment amount is a programmable percentage enrichment. 0% implies no enrichment, 

whereas 100% would double the normal amount of fuel. 

 

The number of crankshaft rotations for which this enrichment is applied can also be specified. During this 

period, the fuel enrichment will gradually decay so that by the end of the after start enrichment period the ECU 

will be operating solely from the main fuel maps. 

 

With correct settings, there should be a smooth transition between cranking and running conditions. As with 

other values, click ‘Save settings’ to store new settings in the ECU memory. 
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Idle valve duty (cranking) 

 

 

 

When starting the engine, we also need to specify the quantity of air that is required. This is governed by the 

idle control valve. In cold temperatures, more air is required to provide a higher engine speed. To access the 

settings for the idle control valve when cranking, click ‘Cranking/startup > Idle valve setting’. 

 

Typical settings would range from ~55% when cold down to ~30% when hot. With the idle valve duty set 

correctly, the engine should fire without needing to press the throttle pedal at all. 

 

It is important that the idle valve duty doesn’t 

change too suddenly. This can cause the engine 

speed to over correct, either stalling the engine 

or overshooting the target idle speed. 

 

Therefore, a further setting (idle valve decay) 

can be accessed under ‘Cranking/startup > Idle 

valve decay’.  

 

The aim of this setting is to smooth the 

transition from cranking to running, so if there is 

any difference in the idle valve duties in the two 

modes, the change will be performed gradually. 

 

Cranking Advance & RPM 

 

It is possible to specify the RPM range that is considered as ‘cranking’. This is useful because a large V8 engine 

will have a much lower engine speed during cranking than a small four cylinder. To access this setting, click 

‘Cranking/startup > Cranking RPM’. A typical setting would be 450 RPM. In this case, whenever the engine 

speed drops below 450 RPM, the cranking maps would be used. 

 

Finally, ignition advance can also be specified under cranking conditions. To access this setting, click 

‘Cranking/startup > Ignition advance’. Typical ignition advance will be in the range of two to five degrees at 

cranking speeds. 
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Fuel maps 

 

The ECU has two fuel maps which are switchable whilst the engine is running. This gives the option of choosing 

either performance or economy settings. For more information see the ‘Map switching’ section.  To access the 

fuel maps, click either ‘Fueling > Primary fuel map’ or ‘Fueling > Secondary fuel map’. For easy access, you can 

also press F2 or F4 to view the fuel maps. 

 

 

 

The ECU has an adjustable injector resolution of between 4 microseconds and 80 microseconds (µS). By 

default, fuel maps display an ‘incremental’ view. This is where each fuel site is a multiplier of the injector 

resolution.  

 

To set the resolution, click ‘Fueling > Injector resolution / MSPB’. Here you can specify the multiplier (actually 

measured in microseconds per bit, or MSPB). For large fuel injectors you will typically use a small MSPB figure. 

This increases the accuracy with which you are able to control fueling. 

 

Note that fuel maps can only accept a value of between 0 and 255, so if you use small injectors and a small 

MPSB value you may actually run short of fuel under full power. To correct this, increase the MPSB value and 

tick ‘Rescale fuel maps to suit new resolution’; this will automatically correct your fuel maps without you 

needing to start from scratch on your mapping work. 

 

As an example of fuel injector operation, if your MSPB figure is set to 64 microseconds, a fuel site with the 

incremental value ‘54’ would actually hold the injector open for 

 

54 x 64 = 3456 µS    (or 3.456 milliseconds) 

 

This figure excludes the injector opening time and any acceleration enrichments which are also added on to 

calculate the total injector pulse width.  
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To program the fuel map, move to the site you want to alter using the arrow keys on your keyboard. 

Alternatively, you can use the cursor to select a site. You can then either type in a numerical value and press 

‘Enter’ or use the ‘Page Up’ and ‘Page Down’ keys to increase or decrease the fuel quantity. Remember that 

every increment will add to the total injector flow time, and therefore enrichen the air fuel mixture.  

 

To adjust more than one site at a time, you can click and drag over the sites you need to change. This will 

highlight them in yellow. You can then enter a new value, subtract a certain amount or add a certain amount. 

 

Like all other maps, when you have finished making changes, click ‘Save settings’ to permanently store the 

changes in the ECU memory. 

 

Along with the incremental view, the fuel map can also be viewed in actual time units (milliseconds), or in 

terms of injector duty cycle percentage. The duty cycle view is particularly useful, as it will indicate whether the 

fuel injectors are likely to have reached their maximum possible flow rate. 

 

 

To change fuel map view, click on ‘View’, and then select either 

‘Incremental’, ‘Time (ms)’ or ‘Duty cycle (%)’. The duty cycle view will 

naturally display higher percentages at high RPM readings and under heavy 

load. 

 

When programming the fuel map, it can be useful to enable the ECU trace 

facility. To do this, click ‘Trace ECU’. The site you are editing will 

automatically follow the ECU, so you can adjust fuel mixture whilst watching dyno power outputs or AFR 

readings instead of looking at the computer screen. 

 

You are also able to program the fuel map via a 3D visual representation. To view the representation click 

‘View cruise (3D)’. 
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The 3D representation draws the fuel map as a three dimensional shape, making it easy to spot spikes or 

troughs in the fuel map. Typically, a smooth transition between fuel sites will be reflected in an equally smooth 

drive quality once the mapping process has been finished. 

 

As with traditional table-based mapping, you can use the arrow keys to move to the site that you’d like to 

change. Then simply use ‘Page up’ and ‘Page down’ to adjust the fuel mixture as necessary. You can also press 

the ‘S’ key on the keyboard to permanently save any changes to the ECU. 

 

Fuel Cut Rev-limiting 

 

The ECU has the ability to cut fuel injection at a user 

defined engine speed. In factory Motronic 

installations, the fuel cut acts as a rev-limiter. 

 

To access the fuel cut settings, click ‘Fueling > Fuel cut 

rev-limiter’. Both hot and cold settings are available, 

so it is recommended to use a lower rev limit when 

the engine is cold to prevent damage. 

 

There is also an option to alternate the fuel cut 

between cylinder banks, cutting fuel once every two 

crankshaft revolutions. This has a less profound 

effect, so use with caution. 

 

Re-scaling injectors 

 

If it is necessary to replace the fuel injectors with 

those of a different size, all fuel parameters in the 

ECU can be modified accordingly. Click ‘Fueling > 

Re-scale flow / pressure’. 

 

It is a simple case of entering the old injector flow 

rate and the new flow rate (both in cc/min). If the 

fuel pressure is remaining unchanged, enter the 

same values for new and old fuel pressure. Now 

click ‘Save settings’ once only. The cranking settings, 

main maps and acceleration enrichments are all 

adjusted to compensate for the change in flow rate. 

 

If a change in fuel pressure is necessary, enter the 

same flow rates for ‘Old injector size’ and ‘New 

injector size’. Now enter old & new fuel pressures 

(both measured in Bar), and click ‘Save settings’. 
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Transient Fueling 

 

The main fuel maps should be programmed to provide adequate fueling for a smooth driving style under all 

speed and load conditions. However, under rapid acceleration or aggressive driving, extra fuel enrichment may 

be required. This is the equivalent of a pump jet on a carburettor. 

 

To view the acceleration enrichment settings, click ‘Transient fueling > Thresholds and enrichments’. 

 

 

 

Enrichment is triggered by rapid depression of the throttle pedal (which in turn operates the throttle position 

sensor). The sensitivity of this trigger depends on the ‘Delta load threshold’ setting. A low percentage value will 

easily be triggered, whereas a high value will need the throttle pedal to be depressed very quickly before 

triggering takes place.  

 

To test the threshold value, press the accelerator and keep an eye on the box that reads ‘Constant speed’. If 

this box turns orange and instead reads ‘Accelerating’, the threshold has been reached and acceleration 

enrichment enabled. The threshold should be set so that it is triggered by heavy acceleration. 

 

You have five separate threshold values, which should increase from left to right, as in the screenshot above. A 

typical minimum value for activation is 3 – any less than this and you risk activating the transient enrichments 

through normal driving which will simply waste fuel. 

 

The ‘Enrichment’ values correspond to the amount of extra fuel that will be injected into the engine once 

acceleration enrichment has been triggered. Start with a low value to avoid flooding the engine. Increase the 

value until the engine accelerates smoothly. Remember to test this setting under realistic driving conditions; 

it’s unlikely that any engine will respond well if the throttle pedal is rapidly pushed to the floor whilst idling.  

 

Naturally, heavy acceleration will require a larger enrichment value than light acceleration to counteract the 

sudden change in air available to the engine. 
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To program the number of crankshaft 

revolutions for which acceleration 

enrichment is applied, click ‘Transient 

fueling > RPM correction’.  

 

You are able to specify the number of 

crankshaft revolutions for which the 

enrichment is applied. Typically you will 

need to apply enrichments for a greater 

number of revolutions at high speed.  

 

 

 

 

The engine will not require as much fuel at high speed. It is therefore possible to specify a percentage of the 

total enrichment to apply between 1000 and 8000 rpm. 

 

To smooth out the transition from acceleration back to normal running, it is possible to taper the enrichment 

back to zero after enrichment has finished rather than abrubtly jumping from full enrichment to no 

enrichment. To do this, click ‘Transient fueling > General setup’. From here you can enable or disable the 

transient enrichment taper.  

 

It is also possible to specify a taper 

quantity (measured in milliseconds per 

rev). A smaller value here will result in 

a more gradual taper, but also have 

the effect of prolonging acceleration 

enrichment. Typical values will be in 

the region of 0.25 milliseconds. 

 

Finally, it is possible to disable 

transient enrichments below a certain 

RPM. Typically this will be set to 

coincide with the idle speed of your 

engine. 

 

You must specify the pin number on 

the ECU that is being used to detect 

transient conditions. Typically, this will 

be a throttle position sensor (in this 

example connected to pin number 

three). 
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Ignition 

 

The ECU supports distributor-based ignition for up to eight cylinders or DIS ignition for engines of up to six 

cylinders. The ECU can operate ignition independently from fuel injection, so programmable ignition can be 

achieved whilst still running carburettors. 

 

Dwell 

 

It is important to set the dwell characteristics in the ECU to suit the type of coils you are using. A dwell time 

that is too high can over charge the ignition coil and result in excessive heat / possible ECU damage. 

Conversely, a dwell time that is too short will not charge the ignition coil sufficiently, resulting in a weak spark / 

misfires under heavy load conditions. 

 

To set the coil dwell time, click Ignition > Dwell v RPM. This will display the following screen: 

 

 

 

You are able to specify dwell times such that they alter dynamically throughout the RPM range. The example 

above shows settings for a DIS coil pack (constant energy ignition – coil charge time does not diminish as RPM 

increases). With distributor based systems it’s vital to decrease dwell time as RPM increases, or excessive heat 

will be generated within the ECU. Contact Canems if unsure. 

 

The dwell time is also corrected with regard to input voltage. To view these settings, click Ignition > Dwell v 

Voltage. 

 

 

 

When the supply voltage drops below 12v, a coil will take longer to charge and therefore the percentage 

correction should be greater than 100%. The opposite is true when the voltage is higher than 12v. The 

correction should always be set to 100% at 12v. 
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Ignition maps 

 

The ignition advance curve is fully programmable. There are two spark maps, each with 252 programmable 

sites between -20º and 49º. The spark maps are switchable at run-time via the map switching input (see Map 

switching). All values are interpolated (averaged) to give a smooth advance curve rather than jumping from site 

to site. However, interpolation can be turned off by setting the ECU into ‘Map mode’, which makes mapping 

much easier. You can access the ignition maps by clicking ‘Ignition > Primary ignition map’ or ‘Ignition > 

Secondary ignition map’. For easy access, you can also press F3 or F5.  

 

 

 

To program an ignition advance site, click the value you wish to modify. Then replace with the new advance 

value and press enter. Alternatively, use the arrow keys to navigate to a site and then use ‘Page Up’ or ‘Page 

Down’ to change the ignition advance. This will send the value to the ECU, which will start to use the new 

settings immediately. The status bar in the tuning software will show ‘Calibration changed’. This denotes the 

ECU settings have been modified, not saved. To store the settings permanently you must click ‘Save settings’. 

 

To view a 3D representation of the ignition map, click ‘View cruise (3D)’. This will launch a new window. The 3D 

view can be useful for smoothing peaks and troughs in the advance curve and ensuring that the map follows a 

general pattern. 

 

When programming the maps, it can be useful to 

have a visual indicator as to where the ECU is 

currently operating. Click on ‘Trace ECU’ either on 

the map itself or the 3D representation. This will 

display a black marker which points to the current 

position / value in the map. This is very helpful 

when mapping the system. 

 

Resistor-type spark plugs should always be used. If 

in doubt, check, because using non resistor plugs 

can produce sufficient electrical noise to interfere 

with the ECU operation. Spark plugs should be 

gapped to approximately 0.035 inch for normally 

aspirated applications. 
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Transient Ignition Advance 

 

 

To prevent excessive strain from 

being placed on the engine, 

limitations can be placed on the 

rate-of-change of ignition 

advance. This is true for both 

advancing and retarding ignition, 

and can be programmed to act 

dynamically throughout the RPM 

range. To view these settings, 

click ‘Ignition > Transient 

Advance’. 

 

Transient advance can be either enabled or disabled using the checkbox. If enabled, the advance settings come 

into play. In the example screenshot above, assuming that the engine is running at 6000rpm, the ECU will not 

allow the ignition to advance more than 2.5 degrees per crankshaft revolution. It’ll not allow the advance to 

retard by more than 6.5 degrees per revolution.  

 

Naturally, higher engine speeds will require a smaller ignition advance or retard limitation. In this example, the 

advance can only increase by 0.5 degrees per crankshaft revolution at engine speeds of over 8000rpm. 

 

Engine Temperature & Air Temperature Adjustment 

 

Along with engine speed and load, ambient conditions can also affect the amount of ignition advance that is 

required. Corrections are therefore available for air temperature and engine temperature. To access these, 

click ‘Ignition > Air temp. adjust’ or ‘Ignition > Engine temp. adjust’. 

 

 

 

It is possible to specify ignition advance correction in 0.5 degree increments, which will act on top of the 

advance figure calculated from the main ignition maps. In the example above, an ambient air temperature of 

fifty degrees Celsius would reduce the total amount of ignition advance by one degree. 
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Rev Limiters  

 

Along with the fuel cut rev limiter (already covered in this 

manual), the ECU can use ignition advance and spark cut 

limiters to form a two-stage ignition limit.  

 

To access the settings for these rev-limiters, click ‘Ignition > 

Rev-limiters’. 

 

The first setting allows different RPM limits, dependant on 

engine temperature.  It is recommended to reduce the 

limits significantly when the engine is cold, with an aim to 

preventing engine damage. 

 

The hard rev limit will cut ignition completely once the 

activation RPM is reached. This will produce a very harsh 

cut which should be used in conjunction with a fuel cut 

limit, to prevent unburnt fuel from igniting when the engine 

speed has dropped. 

 

An option is available to alternate the hard cut limit 

between cylinders. The aim of this is to give a softer impact 

and also prevent the possibility of spark plug fouling after prolonged periods at the rev limit activation point.  A 

fuel cut limiter MUST be used in conjunction with this setting, as the alternating hard cut limiter may not be 

enough to stop the engine. 

 

The soft cut rev limiter reduces ignition to ten degrees BTDC once the activation RPM is reached. Typically the 

activation RPM will be set just slightly lower than the hard limit point, acting to slow down acceleration in 

anticipation of the hard cut. 
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Atmospheric Correction – Cranking / Running 

 

 

 

Dependant upon engine temperature, it is necessary to change the fuel mixture required when the engine is 

cranking. This is similar to operating the choke with a carburettor equipped engine. To alter these settings, click 

‘Atmospheric correction > Cranking correction’. Under normal running conditions (ie. once the engine has fully 

warmed up), the correction percentage should be 100%. This indicates that no extra fuel enrichment is 

required. Under freezing point, enrichment may need to exceed 150%. 

 

Once the engine has moved from cranking to running mode (the engine has started), the fuel correction is 

based on the ‘running correction’ values instead. To access these, click ‘Atmospheric correction > Running’. 

The layout for these settings is as above; a 2D map consisting of engine temperature against fuel percentage 

correction. 

 

Idle correction 

 

Air cooled engines are extremely sensitive to changes in cylinder head temperature at idle. The standard 

cranking/running corrections (described above) may not be enough to produce a smooth idle under all 

conditions. Thus, a further map is available under ‘Atmospheric correction > Idle temperature correction’.  

 

 

 

In the example above, engine load must be under 50%, and speed must be under 1000 RPM before the map 

will come into effect. If these conditions are met, the incremental fuel value from the main fuel maps will be 

added to the temperature-dependant additional value specified here. For example, if the engine temperature 

is sixteen degrees Celsius, the fuel value will be increment by three. Assuming the MSPB value is 64, the fuel 

pulse will be lengthened by (64 x 3) = 192 microseconds. 
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Air Temperature Correction 

 

 

 

 

 

 

 

 

 

 

 

Ambient air temperature has a significant bearing on the fuel quantity required by an engine. Hot air is less 

dense, so less fuel is required to achieve a given AFR target. A 2D map of air temperature against fuel 

correction is therefore available under ‘Atmospheric correction > Air temperature correction’. 

 

Sensor Failure Modes 

 

As the ECU depends heavily on readings from the 

engine temperature and air temperature sensors, 

it’s important that it should know what to do in the 

event of a failure. 

 

Settings under ‘Atmospheric correction > Sensor 

failure modes’ achieve this. Should a reading go 

out of range (due to a wiring fault for example), 

the ECU will default to a certain temperature 

reading instead.  

 

 

Altitude Correction 

 

Most standard Motronic installations have an 

altitude pressure sensor built into the system. 

This is a simple on/off device, indicating whether 

the vehicle is operating in a low pressure area or 

not.  

 

This can be connected to ECU pin 28 or 30, 

depending on the vehicle. Click ‘Atmospheric 

correction > Altitude correction’ to view the 

settings for this sensor. 

 

Fuel can be reduced by a user defined 

percentage if the altitude correction is activated. 
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Oxygen sensing / feedback 
 

The ECU can accept an input signal from either wide band or 

narrow band sensors. The ECU must be programmed to tell it 

which sensor is connected. To program the ECU, click Oxygen 

sensing > Setup. This will display the screen on the right. 

 

To connect a wideband sensor to the ECU, you must program an 

analog output on the wideband sensor such that it gives an output 

of 0V for 10:1 AFR and 5V for 20:1 AFR. This analog output from 

the lambda sensor is then connected to the oxygen sensor input 

(pin 24) on the ECU. 

 

Once connected, a lambda sensor allows real-time monitoring of the air fuel ratio being produced by the 

engine. To view lambda sensor readouts in the software, click View > AFR gauge. 

 

Data logging can also be set up so that AFR inputs are recorded, along with the 

input conditions that produced these results. This can be very useful for 

diagnosing flat-spots or mixture problems in the rev-range. For more 

information see the Data logging section 

 

Note that narrow-band sensors can only give accurate AFR readings in the 

region of 14.7. This AFR is known as the stoichiometric point. Deviations from 

this mixture (either richer or leaner) will not be reflected accurately by the 

software gauges or datalogger, though they will certainly show the general 

pattern. 

 

Once the oxygen sensor has been installed, closed loop feedback control can 

also be implemented. This allows the readings from the oxygen sensor to have 

some authority over the amount of fuel that is being injected into the engine. For example, if the oxygen sensor 

detects a lean mixture, the ECU will add more fuel to compensate – until the oxygen sensor is satisfied. 

 

Due to their limited range of AFR detection, narrow band sensors can only aim for an air fuel ratio of 14.7:1. 

Remember that this is too lean for older designs of engine, and too lean to produce maximum power from 

performance engines. If using a wideband sensor, you can specify a ‘target’ AFR or use a 3D target map. 

 

When using a target AFR, you can tell the ECU to aim for any AFR between 10.0 and 20.0. Alternatively, using a 

3D target map allows you to provide a target AFR for any possible speed or load combination (as per the main 

fuel and spark maps). To view the 3D AFR target map, click Oxygen sensing > Target AFR map. 
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It is important to remember that the oxygen sensor is relatively slow to react to changes in AFR. Therefore, an 

oxygen sensor should never be relied upon to provide accurate fueling when an engine is under full load. 

Instead, set the closed-loop feedback to activate when certain conditions are met. 

 

To view the oxygen sensor feedback settings, click Oxygen sensing > Feedback settings. From here, you can 

enable or disable closed loop feedback control. 

 

There are three enabling requirements, all of which are 

programmable. These requirements must be met before 

closed-loop control activates.  

 

Feedback should be disabled when the engine is cold, 

because we don’t want the oxygen sensor to try leaning 

out a purposefully rich mixture.  

 

Feedback should be disabled above a certain RPM, so 

that there will be no mixture adjustment whilst the 

engine is under load.  

 

Finally, closed-loop feedback should be disabled if the 

throttle is opened more than a certain percentage. This 

will prevent any enrichments from being leaned out 

during heavy acceleration. 

 

The feedback rate is entered in the ‘Check every…’ box. A 

fast feedback rate is not necessarily best, because the 

engine will not respond quickly enough to changes in 

fueling. This can lead to a ‘hunting’ condition, where the 

mixture alternates between too rich and too lean. 
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Idle control – Basic settings 
 

Within the ECU firmware there are essentially three modes of idle control. When cold, the idle valve operates 

in an open loop mode (no feedback from the engine speed sensor is used to adjust the idle speed). When hot, 

the idle valve enters a closed loop mode. The idle speed is automatically adjusted to an idle speed of your 

preference. The third mode of operation is called ‘Idle Decay’. This aims to prevent the engine from stalling if 

the RPM suddenly drops, such as unexpected braking at a junction. The valve will gradually taper the idle speed 

rather than attempting to drop the engine to idle speed immediately. 

 

All two and three wire PWM valves are compatible with the ECU. To access the basic idle control settings, click 

‘Idle control > Idle control settings’.  

 

The first settings you can modify are the enabling 

conditions, used to enter idle decay mode. Normally idle 

decay will trigger when the engine speed drops under 

around 1300 RPM, with light engine load and the throttle 

closed. 

 

To ensure idle decay is not triggered erroneously, there is 

also a setting to re-enable idle decay, once crankshaft 

speed has exceeded a certain limit. In this example, 1800 

RPM. 

 

Closed loop operation should only begin once the engine 

has reached operating temperature. When the engine is 

warming up, it’ll naturally require a higher idle speed. 

 

Therefore, enabling and disabling conditions for closed 

loop control are available. To prevent instability on the 

temperature switchover point, the enabling temperature 

is normally set around ten degrees higher than the disabling temperature. The target idle speed is also 

specified amongst these basic settings. 

 

Idle Valve Warmup 

 
To access the idle valve warmup map, click ‘Idle control > Idle valve warmup’. This reveals a 2D map, specifying 

engine temperature against idle valve duty cycle. These settings form the open loop part of the idle control 

strategy. Duty cycle can be specified to 0.5%, decreasing as engine temperature rises. 
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Idle Valve Decay 
 

Once the ECU enters Idle Decay mode, it aims to 

gradually reduce engine speed until normal idle 

speed is reached. This prevents the risk of stalling or 

misbehaving at junctions.  

 

Three adjustable settings are available, under ‘Idle 

control > Idle valve decay’.  

 

Firstly, the ‘Initial PWM duty increase’. This specifies 

the amount of extra air that is provided when the 

engine drops to idle speed. In this example, the idle 

valve duty cycle increases by 3.5%. 

 

The idle valve duty cycle then decrease by ‘PWM 

decay step size’ every ‘Decay rate’ seconds. The duty 

cycle continues to decay until it reaches the value  

that you’ve specified in the Idle Valve Warmup map. Naturally this is temperature dependant, so the idle decay 

feature works successfully throughout the warmup cycle. 

 

 

Idle Valve Closed Loop 
 

To enable closed loop idle control, click ‘Idle 

control > Idle valve closed loop’. From this 

menu, you can enable closed loop control. 

 

To calculate duty cycle, the 2D Idle Valve 

Warmup map is used as a starting point. 

The engine speed is then analysed by the 

closed-loop software. If it’s too fast, the 

duty cycle will be reduced. Conversely, if the 

engine speed is too slow, duty cycle 

increases. 

 

Incorrect settings can therefore easily 

create a ‘hunting’ idle with an unsteady 

RPM. 

 

You are able to specify minimum and maximum duty cycles. These settings prevent over-correction from the 

closed loop software. The ‘Check RPM every X seconds’ figure is important for a stable idle too. It’s important 

that the engine has long enough to respond to a change in duty cycle, but also that the RPM is analysed 

frequently, so that the RPM can be adjusted quickly enough. 

 

At the bottom of the menu, there is a 2D correction map. This gives you control over the idle valve response 

during closed loop operation. When the idle speed is too low, the correction percentage is a positive number. 

This indicates that the idle valve duty should increase. When the idle speed is too high, the correction 

percentage is a negative figure. This will reduce the idle valve duty cycle and reduce the amount of air available 

to the engine. If the idle speed is perfect, the correction should be zero, indicating that no change is required 

from the current idle valve duty cycle. 
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PWM Valve Fuel Correction 
 

If you are using a throttle position sensor 

to measure engine load, you can still use a 

PWM idle valve. 

 

However, because there is no automatic 

mixture enrichment due to higher manifold 

pressures (as there is with a MAP/MAF 

sensor), we must use PWM valve fuel 

correction. This option is available under 

‘Idle control > Idle valve fuel correction’.   

 

The PWM duty should range from the 

lowest percentage to the highest 

percentage in your Idle Valve Warmup map. When the PWM duty is lowest, fuel correction should be set at 

100%. The correction percentage should then increase from left to right, such that the quantity of fuel 

increases as the idle valve opens. This balances any extra air with extra fuel, keeping the fuel mixture consistent 

throughout the warmup cycle. 

 

Note that the correction figures should always be set at 100% if you are not using a TPS to measure engine load 

and you are not using a PWM idle valve. 

 

Spark Scatter Idle Control 

 

The DRH Performance ECU is also capable of spark scatter idle control. This is where the ignition timing is 

adjusted to maintain a target idle speed. To view the settings click ‘Idle control > Spark scatter idle control’. 

 

To activate spark scatter idle control, click 

‘Enable spark scatter idle control’. The 

‘Maximum ignition advance correction’ figure 

denotes the maximum advance adjustment 

that can be made. In the screenshot above 

for example, if the engine is running with a 

timing figure of 16º, the spark scatter control 

has the authority to move the ignition timing 

anywhere between 8º and 24º. 

 

‘Check every’ is the rate at which the engine 

speed is analysed and, if necessary, 

corrected. If the rate is too slow, the ignition 

advance will not respond quickly to changes 

in engine speed. On the other hand, if the 

rate is too quick, the closed loop control may 

over compensate and cause the engine to enter a hunting condition. Like the PWM valve idle control, the 

correction map is based on the difference between engine speed and target idle speed. If these two speeds are 

equal, there should be no correction. If the engine RPM is too high, the ignition should be retarded so the 

correction value should be negative. The opposite is true when the engine is running too slowly; in this case, 

the ignition timing should be advanced. After changing any settings, remember to click ‘Save settings’. 
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ECU Outputs 

 

The DRH Performance ECU has two general purpose outputs; pin 11 and pin 21. To view the settings for an 

output pin, click ‘Inputs / Outputs > ECU pin X’. 

 

The output pins can be used as 

temperature switches, to operate electric 

cooling fans (via a relay) or to operate a 

temperature warning lamp on the 

dashboard. 

 

They can also be used as RPM switches, 

typically as a gearshift warning indicator.  

 

Finally, the output pins can also be used to 

drive a tachometer with a 12V digital 

output. You can specify the number of 

pulses per crankshaft revolution (eg. three 

pulses per rev. for a Porsche flat-six).  

 

 
 

Air Conditioning Input 

 

Some vehicles fitted with the Motronic ML1.X management 

system were also supplied with air conditioning. 

 

The air conditioning pump can place a heavy load on the 

engine, so it’s important to provide more air. This prevents 

the idle speed from dropping too low.  

 

Pin 29 on the ECU accepts a 12V signal from the air 

conditioning system. When the air con is active, idle valve 

duty cycle can be increased by a specific amount. 

 

To access this setting, click ‘Inputs / Outputs > Air conditioning’. From here, you can enable or disable this 

input pin, and specify the percentage increase in duty cycle. The increase in duty cycle is applied during open 

loop, decay mode, and closed loop idle valve operation. 

 

Switchable Maps 

 

The DRH Performance ECU gives you the option of running two entirely different fuel and ignition maps. This is 

useful if you’re looking for sport/economy modes, or perhaps use two different petrol octane ratings. 

 

To view the settings, click ‘Inputs/Outputs > Switchable Maps’. You can then enable the switchable maps 

function, and specify which input pin you’d like to use on the ECU; either pin 10, 28 or 30.   
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SD Card Datalogging 

 

The DRH Performance ECU can record data logs in real-time to an onboard SD memory card. This can be useful 

either in competition or for diagnosing long-term faults that occur infrequently. Typically the onboard data 

logger operates with a frequency of over 20Hz.  

 

The onboard data logger is turned on and off by a switch (typically dashboard mounted). You must therefore 

specify which input pin is connected to the switch; either pin 10, 28 or 30. To access this setting, click 

‘Inputs/Outputs > Data logging input’. You must also click ‘Enable SD card logging’ before use. 

 

 

 

Before using the SD card data logger, you must erase your memory card. This procedure will remove all 

existing data from the card – make sure you have copied any photographs or documents onto your PC 

beforehand.  

 

The SD card must be fully inserted into the ECU before turning on the vehicle ignition. The card is a gentle 

push-fit into the rear of the unit, with the metal contacts facing upwards (towards the top of the ECU). 

 

Once the SD card is inserted, 

and the vehicle ignition is turned 

on, you’ll notice that the ‘SD’ 

icon in the bottom-right hand 

corner of your screen has 

changed from red to green. 

 

This green ‘SD’ icon indicates that the ECU is successfully communicating with your SD memory card and is 

ready for use. However, before you actually start to data log, you MUST erase the memory card. 

 

To erase the memory card, click ‘Logging > SD Card Read/Erase’. This will display the menu below. 

 

 

To erase the card, simply click 

‘Erase’. This is a quick 

procedure that only takes a 

moment to complete. 

 



 

_ 

Canems Engine Management Solutions 

+44 (0)1724 700222 

www.canems.co.uk               sales@canems.co.uk 

                                         ________________________________________________________________________ 

 

    

35 

Once you have erased the memory card, you are ready to start logging. Simply flip the switch on your 

dashboard, and the data from your engine will be saved automatically. 

 

You can save up to 255 separate data logs on a single card, with the length of each log only limited by the 

capacity of your memory card. Realistically, even a 1GB card will store sufficient data for around one week of 

continuous logging. 

 

To finish an onboard data log, you must turn off the data logging switch on your dashboard. Do not simply turn 

off the vehicle ignition, because the ECU needs to finalise the data and write it to the SD card before power is 

removed from the system. 

 

To download an SD card file, click ‘Logging > SD card read/erase’. The SD card must be inserted in the ECU, 

with the ignition power on. Then click ‘Read’. You will be prompted for a suitable file name (although the 

current date and time is used as a default). Click ‘Save’ to start the download. Download time depends on the 

size of your data log. You are kept up-to-date with progress via the on-screen progress bar. 

 

PC-based Data Logging 

 

If you just need to perform a quick 

data log, and you don’t mind having 

the PC in your vehicle, you can also 

log directly to the PC hard disk.  

 

To do this, click ‘Logging > Start PC 

logging’. You are then prompted for 

a suitable file name (the current date 

and time is used as a default).  

 

Click ‘Save’ to start the download. 

Once you have finished data logging, 

click ‘Logging > Stop PC logging’. 

 

 

When you are data logging (either with the on board memory or via a connected PC), the status bar panels in 

the bottom-right hand corner of your screen will highlight in orange. An example screenshot is pictured below, 

indicating that the PC Data logging is currently active. 
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Log Viewer 

 

Once you have saved a data log (either PC-based or via your SD card), you can use the Log Viewer tool to 

graphically illustrate the engine behaviour. Click ‘Logging > Log Viewer’. 

 

You must then select the data log that you wish to view, by clicking ‘Open log file’. Select the correct file name 

and click ‘Open’. This will display the data in a graphical format as shown below. 

 

 

 

You can zoom in and fast forward in time, using the buttons at the top the screen. You can also export a bitmap 

image file to your PC (ideal for showing to a customer if you have traced a fault on their car). 

 

If you have downloaded the log file from an SD card, it is possible that you might have multiple different logs 

on the same card. The text boxes on the right hand side of the screen will tell you how many separate logs are 

in this file, and you can then use the ‘Next log’ or ‘Previous log’ buttons to swap between them. 

 

Finally, you can choose which items you want to display on the Log Viewer. For example, if you’re not 

interested in engine temperature, simply click ‘Engine temp.’ This will remove the individual trace from view, 

simplifying the readout for you. 

 

Viewing raw data 

 

Data logs from the DRH Performance ECU are saved in a comma delimited file (.csv) which makes it easy to 

import the data into third-party analysis software such as Microsoft Excel®. In most cases, simply double-

clicking on the log file will open your chosen spreadsheet software. You can then build your own charts or even 

write macros to analyse the performance of your engine. 
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 Diagnostics - Maximum / minimum readings 

 

When your PC is connected to the ECU, the maximum and minimum values for all engine parameters are 

stored automatically. This can be of great help if you are trying to diagnose a fault with the engine 

management system. For example, if the maximum engine temperature recorded on a long run is 20°C, it’s a 

fair bet that the sensor or wiring is faulty. 

 

 

To view the maximum/minimum inputs, click 

‘Diagnostics > Min/max inputs’. Similarly, to view 

the maximum/minimum output values, click 

‘Diagnostics > Min/max outputs’. 

 

 

Crank sensor diagnostics 

 

Crank sensors can cause problems on the Motronic ML1.X 

installations, and it doesn’t help that there are two 

sensors that can deteriorate. 

 

Using the DRH Performance ECU, it’s possible to data log 

the first one hundred crank sensor pulses, for both the 

TDC reference sensor and the flywheel speed sensor.  

 

Naturally, the TDC reference time should equate to one 

crankshaft revolutions, whereas the speed sensor time 

should equate to one crankshaft revolution divided by the 

number of flywheel teeth (129 in the case of Porsche 911, 

116 for most BMWs etc.) 

 

To take a crank sensor reading, turn on the vehicle ignition and crank the engine. It doesn’t matter whether the 

engine actually starts or not (making this a valuable diagnostic tool in the event of a non-start situation). Leave 

the vehicle ignition turned on, even if the engine fails to start. Now click ‘Diagnostics > Crank sensors’. This will 

display the screen shown above. 

 

Click ‘Read’ to download the crank sensor pulse times. It will immediately be apparent if there is no activity 

from either sensor, which is the most common failure mode in the case of a non-starting vehicle. 

 

Finally, it is also possible to export the crank sensor diagnostic log into a text (.txt) file. This is ideal if you are a 

mechanic and you have located a problem with a customers’ vehicle. 
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Diagnostics – ECU Data 

 

At any time, you can view raw data as seen by the ECU itself. This can help to diagnose any problems with your 

engine management system. Amongst other readings, you can view the raw analogue-to-digital converter 

(ADC) readings for the oxygen sensor input, pin 2, pin3 and pin7 on the ECU. 

 

To view these ADC inputs in real-time, click ‘Diagnostics > ECU data’. 

 

In use, your ECU should never reset. 

However, if you have a fault with the 

engine management system (such as badly 

corroded earth connections), it is possible 

that this could occur. In a moving vehicle, 

this will be felt as a short misfire. 

 

The DRH Performance ECU records any 

such faults, andthese are displayed in the 

‘ECU data’ box. 

 

Firstly, the ‘CPU reset status’ records any 

faults with the power supply to the ECU. It 

is normal for the ‘Power on resets’ figure 

and the ‘Brown out resets’ figure to 

increase by one count, every time you 

start the engine.  

 

If these figures are increasing when the 

engine is running, or they correspond with 

a misfire, there is a power supply issue. 

 

If a fault is detected with the crank sensor inputs, the ECU will also reset and record a fault code. This is 

because it has lost the location of TDC and needs to relocate the crankshaft position. Thus, if the ‘Sensor 

rejections’ figure is increasing, corresponding with a misfire, then you have a fault with the crank sensor and/or 

associated wiring. 
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Diagnosing Faults 

 

It is not possible for the DRH Performance ECU to function correctly if you already have a fault with your engine 

management system. Ensure that any problems with the factory-fitted Bosch Motronic system are resolved 

before the ECU is replaced.  

 

Naturally you can use the DRH Performance ECU as a ‘known-good’ unit if you are having problems with a 

vehicle. You can also use the data logging features and real-time readouts to pin point any existing problems. 

 

Symptom Check list 

No start · Check that the ECU has a 12V power supply at ECU pin 18 and 35. If not, suspect 

main relay or poor earth connections. 

· Does the fuel pump run for two seconds when the vehicle ignition is turned on? If 

not, suspect main relay or poor earth connections. Check for 12V at fuel pump 

connections. Possible faulty fuel pump. 

· Check for spark at sparking plugs. If no spark, suspect coil(s), power supply. 

· Check for 12V at fuel injectors. 

· Check for adequate fuel pressure at injector fuel rail. 

· Faulty crank sensor(s). Check using crank sensor diagnostic tool in ECU. 

Hesitating / misfiring  

under load 

· Defective air flow meter (if fitted). Use data logger to check for uneven output 

signal. 

· Poor fuel supply. Replace filter, check fuel pressure, clean fuel injectors. 

· Poor spark quality. Check condition of ignition components. 

Rich mixture · Check engine temperature / air temperature sensor operation 

Hunting at idle · Idle speed requires manual adjustment 

· Vacuum leaks (manifold to cylinder head) or vacuum piping to fuel pressure 

regulator and/or accumulator. 

Stalling · Idle speed requires manual adjustment on throttle body. 

· Dirty or sticking idle valve unit – remove and clean or replace. 

Misfiring at high RPM · Make sure all earth points are very clean. Particularly battery to chassis, and main 

engine management loom to engine block. 

· Crank sensor gaps to flywheel are too small. 

· Insufficient fuel. Check fuel pump and or regulator. 

Backfiring · Non-resistor type spark plugs fitted. 

· Poor earth connections. 

· Inadequate fuel supply. 

 

Power supply 

 

If you are unable to communicate with your ECU unit, via the connected PC, it is possible that no power is 

reaching the ECU. You should also hear the fuel pump run for two seconds when the vehicle ignition is turned 

on. Failure of both of these tests would indicate a problem with the main relay; a common fault with the 

Motronic 1.X systems. 

 

If you have an intermittent power supply issue (normally caused by a faulty main relay with poor contacts), it is 

likely that you’ll experience stumbles or misfires on a running vehicle.  
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To diagnose an intermittent power supply problem, click ‘Diagnostics > ECU data’. 

 

 

 

The ‘Power on resets’ figure and ‘Brown out 

resets’ figure should not increase when the 

engine is running. 

 

A perfect reading here would be one; indicating 

that 12V power was applied to the ECU and the 

engine started in one attempt. 

 

It is common for poor earth connections to cause 

these symptoms too. Ensure that the 

connections from battery to body, body to 

engine and wiring harness to engine are 

scrupulously clean. 

 

 

 

 

Closed throttle / open throttle switches 

 

It is common for the throttle switches to cause problems with Motronic 1.X systems. The delicate micro-switch 

contacts suffer from exposure to heat and dirt. 

 

Click ‘Diagnostics > ECU data’ to view the raw 

ADC data visible to the ECU.  

 

‘Pin 3 raw ADC’ should change markedly in 

response to full throttle (press the accelerator 

pedal to the floor). 

 

Failure usually results in a lean fuel mixture at 

full throttle. 

 

‘Pin 2 raw ADC’ should change markedly as soon 

as you apply light pressure to the throttle pedal. 

 

Failure usual results in an unstable idle with an 

excessive idle speed. 
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Air flow meter 

 

The air flow meter acts in the same manner as a potentiometer, so it is expected that the output signal will be 

smooth with no sudden peaks and troughs. The best way to analyse this output is to perform a data log (see 

PC-based data logging). 

 

 

 

This example data log 

represents the output 

from an air flow meter in 

perfect working order. 

With a faulty sensor, you 

will typically recognise a 

sudden drop in output 

voltage – corresponding 

to a worn or dirty carbon 

track inside the air flow 

meter itself. 

 

 

 

Speed sensor / TDC reference sensor  

 

If you suspect that the speed sensor or TDC reference sensor may be faulty, there are three possible diagnostic 

checks. Firstly, if the engine will not start at all, look at the main dashboard when you start the DRH 

Performance Tuner software. 

 

 

 

Initially, the two boxes (circled) will read ‘No signal’. Once the ECU successfully receives a signal, during 

cranking, these two boxes will change in colour, and then read ‘OK’. If this is not the case, replace the defective 

sensor and/or check the wiring loom for faults. 
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If the engine has difficulty starting in certain conditions (ie. damp / very hot / very cold), you can record the 

input signals from each crank sensor for the first one hundred input pulses. This has already been covered in 

the section entitled ‘Crank sensor diagnostics’. After the first twenty or so pulses, the times between crank 

sensor events should remain constant. That is, until the engine fires (when the times will drop significantly due 

to increasing crank speed). 

 

Finally, the ECU will also record any faults when the engine is actually running. Normally a crank sensor fault 

will result in a harsh misfire or stumble, only lasting a fraction of a second. This is because the ECU needs to 

relocate TDC before it can safely continue. 

 

Click ‘Diagnostics > ECU data’ to analyse the crank sensor 

behaviour. 

 

Any faults caused by the crank sensors will be recorded in 

the ‘Sensor rejections’ box. This number increases every 

time the ECU has attempted to find TDC. 

 

Normally this should only occur during cranking of course. 

 

If faults do occur here, it’s most probable that the speed 

sensor is at fault, rather than the TDC reference sensor. 

 

Engine / air temperature sensors  

 

It is best to analyse the behaviour of the temperature sensors using the data logger (see ‘PC-based data 

logging’). As with the air flow meter, no sudden peaks or troughs should be visible in the data log – the plots 

should represent a steady increase in temperature as the engine warms through fully. 

 

In certain applications, the temperature sensors do not have a dedicated earth pin – instead, they earth 

through the engine block. This can result in small ripples in the temperature reading (shown in the plot below). 

This is perfectly normal background noise, but highlights the importance of cleaning all earth points. 
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ECU Pin Functions 

 

Pin no. Function  Pin no. Function 

1 Ignition output 1  19 Earth 

2 Pin 2 ADC (Closed throttle)  20 Main relay switched earth 

3 Pin3 ADC (Open throttle)  21 Pin 21 output 

4   22 Air temperature 

5 Earth  23 Earth (shielded cabling) 

6 Earth (Air flow)  24 Oxygen sensor ADC 

7 Pin 7 ADC (Air flow signal)  25 TDC reference signal 

8 Speed sensor earth  26 TDC reference earth 

9 Air flow meter 5V supply  27 Speed sensor signal  

10 Pin 10 input  28 Pin 28 input 

11 Pin 11 output  29 Air conditioning input 

12   30 Pin 30 input 

13 Engine temperature  31 Ignition output 2* 

14 Injectors bank 2  32 Ignition output 3* 

15 Injectors bank 1  33 Idle valve output A 

16 Earth  34 Idle valve output B 

17 Earth  35 12V supply 

18 12V supply    

 

* With Porsche 944 Turbo firmware, these pins can also communicate with the knock unit: 

Pin 31 – Trigger signal to KLR (knock sensing) unit 

Pin 32 – Input from KLR (knock sensing) unit  
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Ignition system (standard distributor based) 

 

 

Closed throttle switch 

       

 

Open throttle switch 

 

 

Speed sensor 
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TDC Reference sensor 

    

 

Air flow meter (incorporating air temperature sensor) 

 

 

Input pin 10 / Input pin 28 / Input pin 30 

               

 

Injector bank 1 / Injector bank 2 
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Main relay output (switched earth) 

    

 

Output pin 11 / Output pin 21 

 

 

When used as an 

on/off switch  

(eg. cooling fan or 

 shift light control). 

 

 

 

When used as a 

12V square-wave  

tachometer 

output (connect 

pin directly to tach) 

 

 

 

 

Engine temperature (Pin 13) / Air temperature (Pin 22) 
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Idle Speed Control Valve 

 

 

Lambda Sensor 

 

If using wideband lambda sensor, connect ECU pin 24 to wideband analogue output (0 – 5V). 
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Upgrading your ignition system 

 

With the DRH Performance ECU, it’s possible to upgrade your ignition system in a variety of ways. The ECU 

contains three high current ignitors, so it is suitable for running up to six cylinders with distributorless ignition 

(DIS). Alternatively, the ECU can also interface with logic-level external ignitors or pencil coils via the same pins 

on the connector. It’s therefore important to correctly configure your software to match your hardware on the 

engine itself. 

 

Single coil, single distributor (stock Motronic) 

 

Click ‘ECU setup > Basic setup’. Then select ‘Standard 

distributor’ and save settings. 

 

Pin number 1 (Ignition output 1) on the ECU is connected 

directly to the negative terminal on the ignition coil. The coil 

is fired by the onboard ignitor, which also acts as a current 

limiter. 

 

It’s important to ensure that dwell times are not excessive; 

this can result in excessive heat within the ECU. If in doubt, 

contact Canems. 

 

Two coils, two distributors (twin-plug conversion) 

 

It’s particularly common with air cooled Porsche engines to 

add a second spark plug to each combustion chamber. 

Normally this is referred to as ‘twin-plugging’. This modification was introduced as a factory standard starting 

with the 964 models.  

 

To fire a second coil, select ‘ECU setup > Basic setup’. Then select ‘twin plug distributors’ and save settings.  

 

Pin number 1 (Ignition output 1) is connected directly to the negative terminal of the first ignition coil. Pin 

number 31 (Ignition output 2) is connected directly to the negative terminal of the second ignition coil. Both 

coils are fired by onboard ignitors, also acting as current limiters. 

 

Distributorless (wasted spark) 

 

From the TDC reference sensor, the ECU knows the location of top-dead-centre. It’s therefore possible to run 

an engine via distributorless coil pack (each spark plug fires on both compression and exhaust strokes). This 

eliminates the king lead, rotor arm and distributor cap and also provides constant-energy ignition throughout 

the RPM range – there’s no decrease in dwell time at high speed, as there is with a single coil system. 

 

Select ‘ECU setup > Basic setup’. Then select ‘Distributorless (wasted spark)’ and save settings. 

 

The ECU is connected directly to the DIS coil pack, with the coils (two for four cylinder engines or three for six 

cylinder engines) being fired by onboard ignitors. 
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Distributorless (pencil coils) 

 

In this mode, the ECU outputs a logic level pulse, which is designed to interface to external ignitor units. None 

of the high-current switching is actually performed internally in the ECU. In the case of modern pencil coils, the 

ignitor units are actually built into the top of the unit. 

 

To activate the logic-level drivers, click ‘ECU setup > Basic setup’. Then select ‘Distributorless (pencil coils)’ and 

save settings. The ouput from the ECU is as follows: 

 

 

ECU connections with distributorless modes 

 

Whether you’re using the internal ignitors (‘Wasted spark’) or driving external ignitors via the logic level 

outputs (‘Pencil coils’), it’s very important to ensure the correct firing order. 

 

The three ignition outputs from the ECU fire in sequential order, starting with number one. 

 

For a four cylinder engine (firing order 1-3-4-2), the coil(s) for cylinder numbers one and four would be 

connected to ECU pin 1 (Ignition output 1). The coil(s) for cylinder numbers three and two would be connected 

to ECU pin 31 (ignition output 2). 

 

For a six cylinder engine (firing order (1-6-2-4-3-5), the coil(s) for cylinder numbers one and four would be 

connected to ECU pin 1 (Ignition output 1). The coil(s) for cylinder numbers six and three would be connected 

to ECU pin 31 (ignition output 2). The coil(s) for cylinder numbers two and five would be connected to ECU pin 

32 (ignition output 3). 

 

Upgrading your injection system 

 

Standard Bosch Motronic ML1.X systems use low resistance (‘peak and hold’) injectors. The DRH Performance 

ECU will control these injectors effectively and will also control modern high resistance (‘saturated’) injectors. 

In a custom-built injection system, it is normally preferable to use the modern saturated injectors. These 

produce very little electrical noise compared to their earlier counterparts.  

 

To choose the fuel injector style, click ‘ECU setup > Basic setup’. Simply choose which style of injector you are 

using and then click ‘Save settings’. 


